Microinvest Форум Форуми Microinvest Форум
Microinvest Форум
 
 Въпроси/ОтговориВъпроси/Отговори   ТърсенеТърсене   ПотребителиПотребители   Потребителски групиПотребителски групи   Регистрирайте сеРегистрирайте се 
 ПрофилПрофил   Влезте, за да видите съобщенията сиВлезте, за да видите съобщенията си   ВходВход 

Инсталация на WO на Lubuntu (Ubuntu 16.04.1 LTS)

 
Създайте нова тема   Напишете отговор    Microinvest Форум Форуми -> Warehouse Open за Linux
Предишната тема :: Следващата тема  
Автор Съобщение
aptucta



Регистриран на: 03 Мар 2016
Мнения: 18

МнениеПуснато на: Съб Юли 23, 2016 14:50    Заглавие: Инсталация на WO на Lubuntu (Ubuntu 16.04.1 LTS) Отговорете с цитат

Здравейте,
Опитвам се да инсталирам WO на лубунту, но имам проблем. Инсталирах лубунто и го ъпдейтнах до последната версия. Инталирах Mono Complete.

Ето това правя общо взето и не тръгва иска си го това libmono и не ще.

The following packages have unmet dependencies:
warehouseopenplus : Depends: libmono-corlib4.0-cil (>= 2.10.5) but it is not installable


sudo apt-get install libmono-corlib4.0-cil
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package libmono-corlib4.0-cil is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
mono-reference-assemblies-4.0 mono-devel

sudo apt-get install mono-reference-assemblies-4.0 mono-devel
Reading package lists... Done
Building dependency tree
Reading state information... Done
mono-devel is already the newest version (4.2.1.102+dfsg2-7ubuntu4).
mono-devel set to manually installed.
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
warehouseopenplus : Depends: libmono-corlib4.0-cil (>= 2.10.5) but it is not installable
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).


sudo apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following packages will be REMOVED:
warehouseopenplus
0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 61,3 MB disk space will be freed.
Do you want to continue? [Y/n] y
(Reading database ... 155715 files and directories currently installed.)
Removing warehouseopenplus (1.15.3.16) ...
Processing triggers for hicolor-icon-theme (0.15-0ubuntu1) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu5) ...
Processing triggers for mime-support (3.59ubuntu1) ...

sudo apt-get install mono-reference-assemblies-4.0 mono-devel
Reading package lists... Done
Building dependency tree
Reading state information... Done
mono-devel is already the newest version (4.2.1.102+dfsg2-7ubuntu4).
mono-devel set to manually installed.
The following NEW packages will be installed:
mono-reference-assemblies-4.0
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 4096 kB of archives.
After this operation, 18,1 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://bg.archive.ubuntu.com/ubuntu xenial/universe i386 mono-reference-assemblies-4.0 all 3.12.1+dfsg-1 [4096 kB]
Fetched 4096 kB in 3s (1236 kB/s)
Selecting previously unselected package mono-reference-assemblies-4.0.
(Reading database ... 153534 files and directories currently installed.)
Preparing to unpack .../mono-reference-assemblies-4.0_3.12.1+dfsg-1_all.deb ...
Unpacking mono-reference-assemblies-4.0 (3.12.1+dfsg-1) ...
Setting up mono-reference-assemblies-4.0 (3.12.1+dfsg-1) ...


sudo dpkg -i WarehouseOpenPlus.deb
Selecting previously unselected package warehouseopenplus.
(Reading database ... 153637 files and directories currently installed.)
Preparing to unpack WarehouseOpenPlus.deb ...
Unpacking warehouseopenplus (1.15.3.16) ...
dpkg: dependency problems prevent configuration of warehouseopenplus:
warehouseopenplus depends on libmono-corlib4.0-cil (>= 2.10.5); however:
Package libmono-corlib4.0-cil is not installed.

dpkg: error processing package warehouseopenplus (--install):
dependency problems - leaving unconfigured
Processing triggers for desktop-file-utils (0.22-1ubuntu5) ...
Processing triggers for mime-support (3.59ubuntu1) ...
Processing triggers for hicolor-icon-theme (0.15-0ubuntu1) ...
Errors were encountered while processing:
warehouseopenplus

Благодаря за вниманието
Върнете се в началото
Вижте профила на потребителя Изпратете лично съобщение
Виктор Павлов
Microinvest
Microinvest


Регистриран на: 12 Авг 2002
Мнения: 19081

МнениеПуснато на: Нед Юли 24, 2016 09:16    Заглавие: Отговорете с цитат

Ще проверим и ще дадем инструкции.
_________________
Клиентите на Microinvest по света: http://www.microinside.ru
Върнете се в началото
Вижте профила на потребителя Изпратете лично съобщение Изпрати мейла Посетете сайта на потребителя
aptucta



Регистриран на: 03 Мар 2016
Мнения: 18

МнениеПуснато на: Пон Юли 25, 2016 20:53    Заглавие: raboti Отговорете с цитат

Сега го тествах на лубунто 15 и работи без да дава грешки при инсталацията
Върнете се в началото
Вижте профила на потребителя Изпратете лично съобщение
Боян Нейков
Microinvest
Microinvest


Регистриран на: 06 Юли 2016
Мнения: 53
Местожителство: Варна

МнениеПуснато на: Пон Юли 25, 2016 22:30    Заглавие: Отговорете с цитат

Пробвахте ли да си дръпнете просто инсталацията на libmono и да я инсталирате ръчно?
Върнете се в началото
Вижте профила на потребителя Изпратете лично съобщение
aptucta



Регистриран на: 03 Мар 2016
Мнения: 18

МнениеПуснато на: Чет Юли 28, 2016 10:45    Заглавие: Отговорете с цитат

Аз инсталирах mono complete. И не искаше. Как да инсталирам ръчно това моно? Ако не е фатално за програмата мисля да я ползвам на 15, щом се имсталира без грешки.
Върнете се в началото
Вижте профила на потребителя Изпратете лично съобщение
Боян Нейков
Microinvest
Microinvest


Регистриран на: 06 Юли 2016
Мнения: 53
Местожителство: Варна

МнениеПуснато на: Чет Юли 28, 2016 11:40    Заглавие: Отговорете с цитат

Пробвайте този link

Дърпате и го инсталирате.

sudo dpkg -i /path/to/deb/file
sudo apt-get install

Aко не Ви е такъв проблем да сте на 15-ката няма проблем да си продължите с нея Wink
Върнете се в началото
Вижте профила на потребителя Изпратете лично съобщение
Виктор Павлов
Microinvest
Microinvest


Регистриран на: 12 Авг 2002
Мнения: 19081

МнениеПуснато на: Нед Юли 31, 2016 21:50    Заглавие: Отговорете с цитат

И напишете за резултата...
_________________
Клиентите на Microinvest по света: http://www.microinside.ru
Върнете се в началото
Вижте профила на потребителя Изпратете лично съобщение Изпрати мейла Посетете сайта на потребителя
Виктор Павлов
Microinvest
Microinvest


Регистриран на: 12 Авг 2002
Мнения: 19081

МнениеПуснато на: Чет Авг 25, 2016 07:45    Заглавие: Отговорете с цитат

Свалете новата версия http://www.microinvest.net/pub/WarehouseOpenNeo.deb и пробвайте. Този път наистина напишете за резултата.
_________________
Клиентите на Microinvest по света: http://www.microinside.ru
Върнете се в началото
Вижте профила на потребителя Изпратете лично съобщение Изпрати мейла Посетете сайта на потребителя
aptucta



Регистриран на: 03 Мар 2016
Мнения: 18

МнениеПуснато на: Чет Авг 25, 2016 16:44    Заглавие: Отговорете с цитат

Аз не написах за резултат защото се отказах от новата версия и съм на старото лубунто на което работи. Има ли някакви подобрения в новата версия за да я инсталирам?
Върнете се в началото
Вижте профила на потребителя Изпратете лично съобщение
Виктор Павлов
Microinvest
Microinvest


Регистриран на: 12 Авг 2002
Мнения: 19081

МнениеПуснато на: Чет Авг 25, 2016 17:01    Заглавие: Отговорете с цитат

Има.
_________________
Клиентите на Microinvest по света: http://www.microinside.ru
Върнете се в началото
Вижте профила на потребителя Изпратете лично съобщение Изпрати мейла Посетете сайта на потребителя
Покажи мнения от преди:   
Създайте нова тема   Напишете отговор    Microinvest Форум Форуми -> Warehouse Open за Linux All times are EET (Източна Европа)
Страница 1 от 1

 
Идете на:  
Не Можете да пускате нови теми
Не Можете да отговаряте на темите
Не Можете да променяте съобщенията си
Не Можете да изтривате съобщенията си
Не Можете да гласувате в анкети


Powered by phpBB © 2001, 2005 phpBB Group
Translation by: Boby Dimitrov